1. #1

    User Info Menu

    Hello all,

    This is my first post since joining.

    I recently purchased a Deluxe 90 used in "Good Condition" online from Guitar Center, along with a lovely Ibanez AF-55, which plays like a dream. Anyway, the Deluxe 90 is a Deluxe headache. The the left side of the amp (Inputs 1 & 2, Volume, Treble, Mid and Bass) doesn't work at all. The right side (Drive, Volume, Treble, Mid, Bass and Reverb) doesn't work either. It's stuck on a channel that hisses when I turn the Drive up slightly, and the volume is stuck at max so I got to use my handy-dandy speed knobs. But the main reason I bought this used was for the Reverb, and the budget I am on.

    Have I bought a lemon? Or am I just dumb and it is an easy fix?

    Thank you for your time,

    Have a pleasant day,

  2.  

    The Jazz Guitar Chord Dictionary
     
  3. #2

    User Info Menu

    I dont knwo about the amp, my forst thoughts are a guarantee at GC.

  4. #3

    User Info Menu

    Not much you can do. Using a good patch cord?
    Quote Originally Posted by NewToThis
    Hello all,

    This is my first post since joining.

    I recently purchased a Deluxe 90 used in "Good Condition" online from Guitar Center, along with a lovely Ibanez AF-55, which plays like a dream. Anyway, the Deluxe 90 is a Deluxe headache. The the left side of the amp (Inputs 1 & 2, Volume, Treble, Mid and Bass) doesn't work at all. The right side (Drive, Volume, Treble, Mid, Bass and Reverb) doesn't work either. It's stuck on a channel that hisses when I turn the Drive up slightly, and the volume is stuck at max so I got to use my handy-dandy speed knobs. But the main reason I bought this used was for the Reverb, and the budget I am on.

    Have I bought a lemon? Or am I just dumb and it is an easy fix?

    Thank you for your time,

    Have a pleasant day,

  5. #4

    User Info Menu

    Quote Originally Posted by NewToThis
    Hello all,

    This is my first post since joining.

    I recently purchased a Deluxe 90 used in "Good Condition" online from Guitar Center, along with a lovely Ibanez AF-55, which plays like a dream. Anyway, the Deluxe 90 is a Deluxe headache. The the left side of the amp (Inputs 1 & 2, Volume, Treble, Mid and Bass) doesn't work at all. The right side (Drive, Volume, Treble, Mid, Bass and Reverb) doesn't work either. It's stuck on a channel that hisses when I turn the Drive up slightly, and the volume is stuck at max so I got to use my handy-dandy speed knobs. But the main reason I bought this used was for the Reverb, and the budget I am on.

    Have I bought a lemon? Or am I just dumb and it is an easy fix?

    Thank you for your time,

    Have a pleasant day,
    I have never dealt with a GC, but it seems to me a prompt replacement and a sincere "Sorry about that" are in order. It's possible a little DeOxit might help, but that should be on the store. Good luck resolving this issue!

  6. #5

    User Info Menu

    Welcome to JGP -- you have found a cool, low-key high-content spot on the internet.

    + + +

    Guitar Denter offers a pretty lengthy return period. If you can't switch channels by hand with the little "Ch Select" button near the Channel 2 volume, it's broken and you should bring it back while you can.

    If it's too late, the advice about using DeOxIt on the jacks is sound. Also, see if you can borrow a Fender foot-pedal and switch it that way.

    All good luck to you

  7. #6

    User Info Menu

    GC really should stand behind that. I'd take it back promptly.

  8. #7

    User Info Menu

    Return. Return.

  9. #8

    User Info Menu

    Quote Originally Posted by Sam Sherry
    you have found a cool, low-key high-content spot on the internet.
    Love that description!