1. #1

    User Info Menu

    It is my portable companion old Micro Cube.

    It plays but no controls work (volume, tone, gain, effects, amps - nothing).. I can reduce volume only with guitar controls.

    It seems like the sounds goes directly...

    I am not good at electronics... what could it be? and how to fix it?

    First I thought maybe there is some secret button I never knew about and I occasionally pressed it..) but I did not find anything like that

    Thanks

  2.  

    The Jazz Guitar Chord Dictionary
     
  3. #2

    User Info Menu

    Well that's weird.

    Did you try pulling/replacing batteries? Do you have an AC adapter for it?

    Does it sound "stuck" on whatever the last working sound was, or does it sound entirely different now?

  4. #3

    User Info Menu

    Thank you for answering, Jeff!

    I tried averything you say -- batteries, adapter... and it sounded kind of 'stuck' - I can't say for sure but it was not much different from what I usually play..

    I gave up but then suddenly it worked - just like that - I strummed a chord and all the effects, gain and other controls in different positions became active..

    I have no idea what it was...

  5. #4

    User Info Menu

    I once had a similar thing happen to my Roland Cube 80XL. One day nothing worked when I turned it on all the indicator lights stayed on but no sound. Including all of the effects indicator lights, whether that effect was engaged or not.On closer inspection I noticed a sticky substance on the control panel. I think someone spilled a soft drink on the control panel. I cleaned off the control panel and worked the control knobs back and forth. I thought it was broke for good.A few days later I tried it again an every thing worked fine. I think it needed to dry out. That was about 5 years ago and so far it has worked flawlessly. I think these Roland Cube amps are indestructible.