Reply to Thread Bookmark Thread
Page 6 of 6 FirstFirst ... 456
Posts 126 to 141 of 141
  1. #126

    User Info Menu

    I have replaced the spring in my mini brute II.

    If the design is similar to yours, the spring reverb is attached to the back cover.
    Open the back cover (screws) and you should see the spring reverb attached with RCA connectors.

  2.  

    The Jazz Guitar Chord Dictionary
     
  3. #127

    User Info Menu

    I opened up my mini brute iv today and found the unit underneath some fiber glass attached to the right inside, looking for the back. It works now so I may leave it alone. Does the three spring really make a difference?

  4. #128

    User Info Menu

    my spring reverb was broken and I replaced with the exact same model.

    even the old and the new of the same reverb tank sounded different.

  5. #129

    User Info Menu

    Hi Max,

    Mine is a Mini Brute IV leather covering with overdrive. The overdrive did work when I got it but no longer does. Ok with me, hated the sound. Got the amp for $50.00. Shipping cost more than amp but I really love it.

    I have a new Eastman ER1 that needs an amp like this to hear it's true worth.

    I got go so excited about fixing the volume slowly dying problem that I scored a new looking 4 ohm Polytone Ext cabinet on eBay for a bit extra volume.

    Does anyone know if this model came with a 3 spring or a 2 spring reverb? Works but as has been said before, not that great a sound.

    thanks!

    tom

  6. #130

    User Info Menu

    I'd have to pop one open and look behind the fiberglas to know, for sure. IIRC, though, I think the reverb tank is a 3-spring in my MiniBrute IV.

    Polytone reverb is okay, but isn't Fender or Ampeg quality. I generally don't use reverb at a level much above 9-0'clock on the dial anyway. I find, when gigging, that the venue gives me the ambient reverberation I need. If I were playing Sergio Leone soundtrack music, OTOH, I'd want gobs of reverb--in which case I'd use my Fender outboard unit. Then, again, I'd probably use my Telecaster and a Fender Deluxe Reverb or Princeton Reverb amp, too.

  7. #131

    User Info Menu

    This is the model used on MB II and Mega Brute.

    Accutronics 8DB2C1C Reverb Tank

    Model number of the tank should be printed on the original tank.
    Last edited by r_cc_c; 03-27-2017 at 01:13 AM.

  8. #132

    User Info Menu

    Quote Originally Posted by Zack
    Hi folks, finally found a tech to have a look at my amp at about 40 mns drive away. But in fact, traffic is so horrid that it took a whole hour.
    He himself found it impossible to date to get his hands on a schema and is still looking. The good news is that the amp is in top condition. The speaker's fine, which I'm relieved about as it'd be next to impossible to find the same.
    The control were tested and they're fine , delivering good ranges of modulation. The only stuff that needs definite attention is the jack input for the guitar lead. He's going to check the whole circuit, etc... & I shld get it back on The 05/05.
    I feel so much better now!

    Sent from my VF-895N using Tapatalk

    tail notes buzzing might be crossover distortion.
    30$. easy fix and common problem with Mb.
    Underside the power amp there a little bias trimmer.
    A good tech may solve polytone’s problems in a couple of hours, cheaply.

  9. #133

    User Info Menu

    @billy21
    Many thanks for your message.
    That is really great to know.
    The tech at the time could not find anything wrong with the amp and I think could not get what I was going on about. This left me thinking I was making stuff up and decided to give up trying to find a fix.
    So I very much appreciate your input here as that confirms to me that this is an issue with the mb. And it's great to know how to phrase it and that it is an easy fix!
    Brilliant! Thanks Solo very much!

  10. #134

    User Info Menu

    you’re welcome zack.

    It’s a very common problem on polytones equipped with LM391 chip.

    Polytone Minibrute II LM391 and bias issues.

    the bias setting is not stable on those amplifiers, are prone to crossover and other problems. Bring it to a good tech and scope it.
    I remember the tech had also isolated the screws on the transistors because are mounted on the dissipators and cause lot of heat and strange “farting” sound.
    They are fragile amplifiers, and you have to be careful when carry it to the car, broken reverbs happen etc..
    They works closed back, stuffed with lots of rookwool inside, it might be a problem to dissipate the circuit heat.
    I have a fuzzy cover Mb IV from 1981 which doesn’t have any problem and sounds great,
    thermally stable.
    Broken reverb unit, replaced with a Belton/accutronic 2 springs 2250/150 ohm medium decay and works well.
    If you got hum like white nose, coming from the amp (without connecting jack cable), it might be a grounding issue, dirty Rca reverb unit plugs or at least big electrolytic capacitors (one or both might be too deteriorated).
    If you don’t have any hum it means the amp is running too cold (underbiased), that’s why you got lots of crossover.




    Another problem that you can have with mb are vibrations, buzzing is coming from brite normal dark switch which are microphonic, or (very common) buzz coming from preamp unit, caused by foam deterioration. Easy fix, just put some pieces of new foam under the unit and check any other elements (pots, screws, cables) that might cause buzzing.

    As you described I’m pretty sure is crossover.

    Let me know if this can help.
    Last edited by billy21; 05-02-2019 at 08:39 AM.

  11. #135

    User Info Menu

    bought a nonworking Minibrute for $100 and got it working with help from this thread. Has the distortion red knob, reverb both of which I never use. Do not play it out for fear of a mid set meltdown. Also have the extension cabinet for it and had the speaker recoded by a guy who knows these speakers. Sounds amazing.

    I love this amp and and never want it to die but am always on the lookout for a replacement for when this happens!

    no purpose for this post except to participate with other Polytone users.

    Glad it is still an active thread!

    tom

  12. #136

    User Info Menu

    The red knob distortion model with cts speaker is the best version.

    Early '80s.

  13. #137

    User Info Menu

    Hey Folks - I am selling a 1 x 15 Mini Brute IV in Pittsburgh. $200. It works. It's missing Grill cloth and Nameplates. It's missing the round thingies that the power chord wraps around.

    Here are a couple pics. Let me know if interested. Will accept reasonable offers. I have had this amp since the late 90s, it was used when I acquired it then.

    If I have mis-identified the model, please enlighten me. Also I have no idea as to its vintage but I know some of you do!

    Ethan

    Polytone Mini Brute IV-img_20211205_143018568-jpg

    Polytone Mini Brute IV-img_20211205_143033387-jpg

    Polytone Mini Brute IV-img_20211205_143005796-jpg

  14. #138

    User Info Menu

    Looks like a good amp for a sweet price

  15. #139

    User Info Menu

    The Baby Brute 8" with a 175/165 unbeatable combination, that said almost every archtop iv plaed with Baby Brute sounds good. Solid bodies dont sound nearly as good, however they do sound good thro Mega Brute 8". Both Baby & Mega have identical 3/4 Ohm Eminnence speakers. My 165 thro a Mega sounds good but not like the Baby Brute.

    Imo cabinet size/volume in conjuction with the 8" speaker makes a huge difference on an archtop. The Little Jazz 8" is smaller than a Baby Brute but not much. Pictures are hard to gauge. The Little Jazz does not sound nearly as good as Baby Brute ( not bad, just different) although LJ digi reverb sucks.

    Baby Brute & Mega Brutes amp sections are similar, but different......... dont know the exact technical terms.
    The orig 1978 1984 Roland Cube 40 & 60 sound good with both archtop and solid bodies

    I know Joe Pass played thro Polytones, but think more of a Gibson & Baby Brute you are really straight into the Wes Pass Tal and all the other players who used Polytone that were perhaps not that well known. This does not mean that the Bigger Polytone like Greentone and others have are not good. i am pretty much saying what Vintage said, with additional blurb. A recent YT of Dutchblogger playing a 175 & Polytone is right in that bag/sound.

    Polytone Mini Brute IV-img_20190308_162221-2-jpg

    Polytone Mini Brute IV-img_20190308_162619-jpg
    Last edited by Durban; 12-08-2021 at 03:56 PM. Reason: sloppy spelling just sloppy thank goodness im not in power

  16. #140

    User Info Menu

    Ps just seen this on another thread, but agree totally




    I want a guitar to produce the sound I hear in my head. And we all hear different things.

    Dutchblogger

  17. #141

    User Info Menu

    My 175 sounded better through my Baby Brute than any other amp, too.

    My solid body guitars sound best through my Mini Brute II.